Thursday, 29 June 2017

The Bumper is on.

I got a chance to fit the bumper today, The usual hassle with bolts not lining up, but it went on in the end.
I like it, it worked out well. Next thing is to wire the cab switches so i can turn the lights on and take a look at them, maybe a bit of alignment as well.

Wednesday, 28 June 2017

Front Bumper Nearly Finished

There is a lot of work gone into this front bumper, I hope its worth it. To be honest it is starting to look the way i imagined it, so that's good.

I now have all the lights mounted in the bumper and wired too the multi-pin connectors, the mating connectors are wired to the truck.
Next step mounting the bumper and testing the lights.

There is three 55watt HID units per side, one is the main truck lighting (Head/Dip) the other two are switchable interdependently and for (Off Road ) use !
i have used LED strips to light up the three lenses on each side, my hope is that it will give enough light to suffice as side lights. I do not really want to add anything else that will take the look off it.
We will see !!

Sunday, 18 June 2017

Fixing a wiring issue

I am very happy today, i just got to the bottom of a wiring fault that has been bothering me for some tome now.
when i collected the truck from the Czech Republic i was a bit excited, as a result i didn't really scrutinize the electrical systems as much as i should have.
I knew that i could easily fix any problems.
Obviously i checked all the lights,horn,and important stuff, but this particular fault is something you just wouldn't look for, so i didn't spot it until we were in Germany on the way home.

I got the guys in the Czech Republic to fit the more modern indicator stalk to the truck for me, it controls main beam flash and on/off and also wipers intermittent/slow /fast, washers and horn. Its a lot neater that the old type controls.

on a coffee stop i removed the key from the ignition,
when getting out of the truck i knocked this indicator stalk and inadvertently switched the intermittent wipers on.  The wipers didn't come on, BUT the ignition did.  Not ideal.

The guy that wired it probably didn't notice this because its not something you would look for, however he was aware that the intermittent wipe function was not working on the stalk, because he had wired a separate switch for that on the dash (very amateur)

the way it was done, meant that if it was just raining slightly you turned the dash switch on, then if it rained heaver you turned the stalk switch on. Of course when it stops raining you then have to turn two switches off.

So for the last two days i have been  tracing this fault.

what i had to work with was:
 a stalk switch with a 8 pin and a six pin connector on it (nothing labeled, no documentation for it, not originally off this truck) making this a real pain to work with.
An intermittent wipe relay with 7 pins (i managed to find the pin-out connections for this)
a wiper motor with 5 connections (standard to the truck, so i had the wiring diagram for it)

After struggling for several hours with this i decided on radical action, i removed the wiper motor, stalk switch and relay for the truck along with the associated wiring loom, i stripped the loom and opened it all up and put it all on the bench to work it out.

As it turned out the fault was on the truck !  They had mistakenly wired a ignition feed to the output of the intermittent wipe switch.
Once i found this and tested my theory, i remade all the looms and refitted them to the truck, i also took a closer look at the timer relay and noticed it had a input from the screen washer switch, to operate the wipers when the screen washer is pressed,  it was not wired,  but is now !

So, long story short, i now have a stalk switch that works properly, no tacky extra switch for wipers, and as a bonus i have wash/wipe function as well.

Friday, 2 June 2017

Even More Bumper

Nearly finished now, just some sanding and filling to do then paint, satin black i think. then its time to fit and wire it.